Jump to content

[IPS] IP.Board 3.3.x, 3.4.x Security Update


Administrator
 Share

Recommended Posts

We are releasing patches for IP.Board 3.3.x and IP.Board 3.4.x to address two cross site scripting issues recently reported to us.

IP.Board takes precaution against cross site scripting issues by ensuring sensitive forms and buttons have a unique key in them and also by ensuring that sensitive cookie data is not readable by javascript. However, we feel that it is in our clients best interest to have these issues resolved.

To apply the patch
Simply download the attached zip for your IP.Board version and upload the files to your forum server. You do not need to run any scripts or the upgrade system.

IP.Board 3.3.x

Attached File ipb33_patch_dec_13.zip   36.27KB  12 downloads

IP.Board 3.4.x

Attached File ipb34_patch_dec_13.zip   53.02KB  36 downloads

If you are an IPS Community in the Cloud customer running IP.Board 3.3 or above, no further action is necessary; we have already automatically patched your account. If you are using a version older than IP.Board 3.3, you should contact support to upgrade.

If you have installed or upgraded to IP.Board 3.4.6 today, no further action is necessary; we have already updated the main download zips.

We extend our thanks to indistic for notifying us of the BBCode issue and Artur Czyż ( http://www.arturczyz.pl ) for notifying us of the search issue.



View the full article
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...