Jump to content

Articles

Articles

Articles

IPS 3.4.x Google Mobile Rendering Issues


Administrator
  • IPS 3.4.x Google Mobile Rendering Issues

 Share

To address this issue, please make the following changes.

1. Admincp > Tools & Settings > User Agent Management > Manage User Agent Groups

Take the Google Mobile user agent and left click and hold on the far left area, and drag it above the google user agent.

View attachment: google mobile1.png

2. Now edit the Google Mobile user agent, and set the regex to the following

iphone;

View attachment: google mobile2.png

3. Now go to your user agent mapping settings on the mobile skin. Admincp > Look & Feel > Manage Skin Sets & Templates.

View attachment: Google Mobile3.png

4. Select make sure to select the following user agents to map to the mobile. Only the Bold Items should be needed, however for testing I used the following, so you can too if you see any issues.

Google Mobile

Transformer Tablet

Android

Firefox Mobile

Blackberry

iPhone

Sony Ericsson

Nokia

Motorola

Samsung

Siemens (Openwave)

Nexus(Google)/HTC

LG

Palm

Opera Mobile/Mini

Windows Phone 8

Webtv

View attachment: Google Mobile4.png

Save, and then test here - https://www.google.com/webmasters/tools/mobile-friendly

If it's not picking up the mobile skin properly, a few issues I ran into were server caches, re-caching the skins in testing worked to flush this. So if it's not working after the above changes, give that a try.

View attachment: gmobile5.png

 Share


User Feedback

Recommended Comments

There are no comments to display.



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...